Questions re: SOG Terminus XR

Joined
Jul 30, 2020
Messages
10
I bought a Terminus XR a few days ago (10/2021), mine has S35VN; this is my first SOG knife. Right out of the box, this knife has been very disappointing. The action on my knife is incredibly stiff. I cannot open the knife with the flipper and I cannot even move the blade with the thumb studs. I tried contacting SOG twice and they did not respond, so I watched some videos. I found a guy who disassembled the knife and lubed it so I thought I would try this. I may have voided my warranty but it doesn't matter since SOG will not respond to me. The knife is back together and it is marginally better. The flipper still does not work but I can open the knife with the thumb studs. The button that lets me close the knife, the XR lock, does not work smoothly. As you might guess this knife has been a big disappointment. I am not counting on any assistance from SOG so do you have any suggestions for making this a usable knife? Thanks.
 

jbmonkey

Supreme windbag
Platinum Member
Joined
Jun 9, 2011
Messages
12,933
don't own this knife, but have a couple xr lock sogs. all came stiff out of the box.....I could always flip them open but not thumbstud push flip them open. weirdly one would kinda lock up closed sometimes and i couldn't push the thumbstud open.. not everytime though.. could always flip it open though,, but stiff push to overcome something. after using for awhile they all worked loose and work fine now both ways.

I didnt take apart or oil anything. they just work fine now from open and close and using.
 
Joined
Dec 9, 2015
Messages
1,476
Where are you fingers when actuate the knife? Could you be by accident putting pressure onto the blade? Also, yes the knife will become yes stiff over more use. Due to the different shape and length of the springs - SOG XR is stiffer to move than the benchmade's omega springs (for example) so you if you don't have a good grip/technique that could be causing the problems. Also, the XR lock isn't a button, wrong word usage or ...? I've spoken/emailed to SOG customer service/warranty multiple times, so not sure why you're having problems.
 
Last edited:
Top