1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

  2. Week 29 of the BladeForums.com Year of Giveaways is live! Enter to win a Ron Flaherty Folder

    Click here to enter the drawing for your chance to win a Ron Flaherty folder , Bladeforums.com swag or memberships!
    Be sure to read the rules before entering, and help us decide next week's giveaway by hitting the poll in that thread!

    Entries will close at 11:59PM Saturday, July 20 ; winners will be drawn on Sunday @ 5pm on our Youtube Channel: TheRealBladeForums. Bonus prizes will be given during the livestream!


    Questions? Comments? Post in the discussion thread here

Mod please help

Discussion in 'Tech Support, General Q&A, Site Feedback & More' started by Kcorange11, Jun 10, 2019.

  1. Kcorange11

    Kcorange11 Gold Member Gold Member

    139
    Feb 4, 2019
    Long story I've short.So been having issues with feedback, will always get a "try again" alert while trying to leave feedback. It's usually a 10 min ordeal and it will finally go through.

    Apparently I left someone neg feedback. I definitely didn't mean to and actually didn't think it went through.

    If a mod could help in clearing @sfknifeguy good name that would be great.

    Thanks!
     
    sfknifeguy likes this.
  2. rycen

    rycen Super Moderator Staff Member Super Mod

    Aug 22, 2002
    You’re all set
     
  3. Kcorange11

    Kcorange11 Gold Member Gold Member

    139
    Feb 4, 2019
    Ty sir. Wasn't sure where to ask for help.
     

Share This Page